Unfortunately I cannot get the image upload to work.  There are 8 components in a line top to bottom.  They alternate in color, green and white.  The styled color is bluish.

I am having two issues with the component (TTMSFMX7SegLED).  One is new since I upgraded to 10.3 and the other may have been there before, I just did not notice it.  This is TMS and Anddroid 5, 6 and 7 on various Samsung devices on Delphi 10.3 professional.

1.  As the attached screenshot shows, one component is the original BLUE color of the IDE styled design.  At the initialization of the screen, every component passes through this procedure to set the color of the 7 segment display.  All eight components sequentially call this procedure. (added last line after reading forum, had no effect)  This has always worked in the past, but does not now.  Any help in looking for the cause will be appreciated.
    procedure ChangeLEDColors(SegmentDisplay: TTMSFMX7SegLED; SegmentColor: TAlphaColor);
         SegmentDisplay.Shape.Fill.Color:= TAlphaColorRec.Black;
         SegmentDisplay.Shape.FillActive.Color:= SegmentColor;
         SegmentDisplay.UpdateLedObjects;  // added this line after looking at forums

2.  The value seems to be truncated.  The green 7 segments are set with 1 digit and 3 decimals and the whitiesh 7 segments are set with 1 digit and 4 decimals.  The value assigned  is of type double.  No matter what value I assign, the green is always rounded to 2 decimal places and the whitish is always rounded to 1 decimal place.  I am pretty sure this used to work at some point in the past, though the current play store version (store update in July 2018) is doing the same thing.  Is there some property I missed that sets this.

I did search the forums, but there were no comments about second issue and the suggestion in the first issue had no effect.


I have received your followup via email and we will further followup from there.

At least for now, I have solved the second issue.  I have had no success
solving the first issue.  I have tracked through the source code the
best I can and everything seems correct.  I deleted the component and
added a new one, and also deleted the component and copied a working one
into the spot.  It still uses the styled color.  I am out of ideas to
try and any guidance where to look would be helpful.