TMSFNCGoogleMaps not working on remote desktop

It is translated with google translate

The maps application is using the TMSFNCGoogleMaps component.

I have a Microsoft Windows Server 2008 R2 Enterprise server, with remote desktop users, where the users directly run the exe application, using the "Start the following program on connection" option. So when they try to access the map it doesn't load the msedgewebview2.exe process, and it doesn't open the map application.
The funny thing is that if I remove the "Start the following program on connection" option, the map application works fine for me.
There is some setting or permission that has to be given to the msedgewebview2.exe application for it to work for all users.


This is an example of the maps application with the "Start the following program on connection" option enabled, where it doesn't load the map it just blanks out the screen.

sin msedgewebview2

This is an example of the maps application with the "Start the following program on connection" option disabled

con msedgewebview2

It's unclear what is going on. We found a similar kind of issue here:

Also, did you install the runtime on Windows Server? (WebView2 - Microsoft Edge Developer)

Is not working

I already made the change in the different options, in administrator mode, and still the msedgewebview2.exe process does not load.

It's unfortunately unclear to me what the cause for this issue is. Potentially the "Start the following program on connection" is disabling features that are required for the application to run. Maybe it is related to administrator settings or elevated settings?

Maybe a workaround is to add a task instead, when someone logs in, it starts the application.

This text was translated with google translator

Good day,
Returning to the subject, they have found a solution to my problem, since the two previous solutions did not work for me, and I actually purchased this product to use the map but it is not working for me in production.

I send you a small video of how the application fails me.
I will explain:

My users enter the point of sale system through remote desktop, and they enter the application directly, they do not have access to the windows explorer.

If you see in the video, in the task manager, when executing the pMapas.exe application, it does nothing, it just gives me a blank screen, and it doesn't load "msedgewebview2.exe", so I have to end the process " pMaps.exe".

The Maps application works correctly for me, only if I run the "explorer.exe" application first, opening the windows explorer, doing this, if I press the Maps button again, it opens the application loading "msedgewebview2.exe".

The attached video is compressed in a .zip file, which is in .mp4 format (1.4 MB)


It's unclear what happens, but this is something related to the browser itself. Please report this bug here: Issues · MicrosoftEdge/WebView2Feedback · GitHub. Assumably, explorer.exe needs to run in order to execute the application, there is nothing we can do about this from here.

Seems that in administrator mode it wouldn't work.

See this topic: Can WebView2 run without explorer.exe shell? · Issue #990 · MicrosoftEdge/WebView2Feedback · GitHub

Maybe you should try to start webview2 from your application forcing non admin privileges.
Another things I would also test would be
1-trying starting it from the gud'old Windows/CurrentVersion/Run, that also would depend on explorer.exe, but at least it would be easier to check those admin/non admin issues
2- setting a custom shell application that would somehow start your map application without admin privileges (instead of using "Start the following program on connection" )
And must make sure that your app doesn't have other explorer.exe dependant components.