TDBAdvGrid - Gallery error message Property DrawingStyle does not exsist

TMS VCL UI Pack v11.0.4.0
Component TDBAdvGrid Version
Delphi 7

On rightclicking the grid and selecting Gallery the error message
'Error reading AdvStringGrid1.DrawingStyle: Property DrawingStyle does not exsist'
is displayed and the gallery does not open. This applies to newly created projects as well as legacy projects; where it did previously work.

I've tried uninstalling and manually deleting all the TMS folders I could find
in documents and appdata then reinstalling

Any help will be greatly appreciated

It loads these settings from *.gp files under \My Documents
I could not see an issue here when trying to reproduce.
These are the files that should be in your \My Documents folder:


Hi Bruno,

Thanks for getting back to me.

Those files exist on my PC in both the default Documents folder (ie C:\Users%username%\Documents) and my actual Documents folder (E:\Documents):

Initially they didn't exist but I had downloaded the file from a previous post where you mentioned this could be an issue. I also tried deleting them and re-running the installer which did not recreate the files in either folder.

Looking at the dates on my install I'm wondering if you have a link to newer versions of the files?

Normally, our installer should have unpacked the latest version of these files on your system.
The latest version of these files are also here: (17.1 KB)

Thank you Bruno.

I've copied those files to both the C:\Users%username%\Documents and my E:\Documents folder and
I'm still getting the same error message. Also tried resetting the Library path to the default C:\Users...

I have tried uninstalling (which didn't remove the .gp files from either folder) and re-installing the latest build.

Is there anyway to check where the component is looking for the files or force the component to look in a different location?

Thanks in advance

It should always look into the current user My Documents folder.
Maybe you start the IDE with a different Windows user?

I activated the Administrator account (Net User Administrator...) and, after re-installing the TMS package and the other libraries I need to compile the program got the same error message.
I left all but the Downloads folder set to Windows Defaults and, again, had to manually extracted the GP files to the documents folder.

Did you search your entire hard disk for old/erratic *.gp files?
Can you check if there is on your machine somewhere old gallery.res files?
I rechecked everything again here and with the latest version of the files, I couldn't see anywhere that DrawingStyle is used.

Hi Bruno,

After searching my PC I did find some old GALLERY.RES in my OneDrive backup and in my local backup folders, which I have now deleted, so the only one on my system is located in:

C:\Users\Reception\AppData\Local\tmssoftware\registered\TMS VCL UI Pack
With a file size of 42.5k dated 13/01/21

I Also found some older .GP files in my backup archive as well as some that seem to have been created during the initial update to v11.0.4.0 (dated Thursday, February 16, 2023; which I did on the 20th) seems to have created the gallery files in my default Documents folder (E:\Documents) BUT they were in a sub folder called tmssoftware.

I uninstalled the package and manually deleted the tmssoftware folder along with the residual files in the %AppData% folder then reinstalled but still get the same error message and this time the gallery files were not automatically created anywhere. I manually recreated these, from the .zip file you sent, in the default Documents folder (E:\Documents) as well as the residual windows folder (C:\Users…).

Don’t know if this could be related, but, I’ve also noticed some of the visualizations in other controls aren’t working; for example a TAdvTaskDialogEx that should show the shield icon in the footer no longer shows the Icon

I'm running out of ideas.
When you open these .GP files with notepad, do you see anywhere in these files the keyword: DrawingStyle?

This keyword should not be there and if you find it, delete the line containing it.

Thanks for being so patient

I copied the .GP files into a single text file and searched for DrawingStyle:

gal.txt (45.4 KB)

and found nothing. In the mean time,as a work around, I used the .GP files as a source file (In Word changing the = to :=, adding quotes a square brackets where needed and putting a ; at the EOL mark) and created a procedure to implement the settings:

CodeSnip.txt (2.1 KB)

I did have to comment out the last few lines as I couldn't find an associated property in the component.
The code is executed from the Forms on Show event and wrapped in a With %gridname& do.
Don't know if that offers any clues?

I'm sorry but it is beyond my understanding why you get an error on DrawingStyle when there is no DrawingStyle in the GP file.