Stopping autocompletion

has anyone successfully done this? We have tried multiple approaches, but Google (and as a result every modern browser) thinks it is ok to just ignore something that is part of the HTML specification.

The only thing I can think of to get around this is changed the field names every time.

Any ideas very welcome.

1 Like

Did you try settings under TWebEdit.AutoCompletion?
Did you try to set this to acNone?

Yes I have tried acNone which adds autocomplete="off"

It's just ignored by all the Chrome based browsers.

setting autocomplete="nope" seems to work

1 Like

It is disturbing that Chrome ignores "off", but we'll add the acNope type so it will be possible to set this from the IDE as well.

1 Like

A colleague has been looking how GMail gets around this - they do a lot of work to break their own rules. For example the Recipients input is a TextArea, and subject has the visible box named "SubjectBox" with autocomplete="off" and a hidden input called subject - and a ton of javascript. Also random Ids maybe too.

Of course no guarantees that nope will continue to work. Actually it looks like any value that isn't an official one. We'll look some more and report back, before you rush off and do it. It maybe an acRandom might be the solution.

after sometime of messing with this it seems that chrome (and all those based on it - i.e. every main browser now) learns and then ignores the autocomplete="nope". The only solution we can think of is setting a random value to autocomplete each time.

One thing is that if you do add this, then it will need to work for templated controls as well.

When it is a templated control, it leaves the autocomplete attribute to the value set in the template.

Yes I know, but could this be a special case as tabindex inadvertently was?

actually we are now not even sure that a random autocomplete on its own is enough.

This of course is a killer for data entry

Stopping Chrome from ignoring autocomplete=off – Adam Silver – Designer, London, UK.

HTML Standard (

Maybe the 'new-password' attribute should be safe?

we are trying this at the moment - will report back

They seem to learn. It now tries autocomplete on "new-password"