Still getting run-time error on with WebStringGrid.Rowcount change at design time

I uninstalled and installed but still getting this error at run-time when I change the rowcount in the designer. Am I missing something?

Uncaught TypeError: Cannot read properties of null (reading 'rows')
    at Object.ColCountChanged (WEBLib.Grids.pas:1113:1)
    at Object.SetColCount (WEBLib.Grids.pas:5277:7)
    at Object.LoadDFMValues (SubPattern1.pas:165:19)
    at Object.CreateNewForm (WEBLib.Forms.pas:3161:8)
    at Object.DoFormLoad (WEBLib.Forms.pas:3244:3)
    at XMLHttpRequest.cb (rtl.js:249:1)

Cannot be reproduced.
Can you make sure you first FULLY uninstalled v1.9.6.0 (via the Windows Control Panel, uninstall all TMS WEB Core entries) and after this, perform a clean fresh install of

Hi I did this, removed both TMS WEB core entries via control panel, did a clean install of and did a reboot before trying again. Still getting the error when updating the rowcount on WebStringGrid. Is there a specific file I can check?

What exact steps to reproduce?

Test here:
Drop TWebStringGrid on the form
Set RowCount = 10 at design time
Compile & run app
-> works as expected.

Is this the same issue reported here? Wondering what release this was fixed in - maybe just a matter of waiting for the next update?

This is fixed in v1.9.6.1.
We cannot see any issue anymore with v1.9.6.1.

I found that if I create a new TMS Core web project and drop a TWebStringGrid on the form, change the rowcount to 10, it actually runs okay. If I go back and run my original project, I still get the error. Note that I am using a WebStringGrid on a Popup form.

I created a new Web form in my original project, and added just a TWebStringGrid to it, made rowcount=10 and also still get the error. Here is how I am invoking the new form:

  SP.Border := fbDialog;
  SP.Caption := 'Substitution Pattern';
  SP.Popup := true;
  await(TSubPattern, SP.Load());

Finally, I simply added a TWebStringGrid to my main form, changed the rowcount to 10 and actually DO NOT get the error. So I'm only seeing this when I invoke a popup form from the main one. Also I am able to adjust the rowcount at runtime with no problems. Only happens when rowcount is changed during design.

I tested this once more adding a TWebStringGrid on the 2nd form in the demo Demo\Basics\Multiform and modified RowCount and showed the 2nd form as popup form and this works as expected. Please look at this demo for how to use popup forms.