sphinx.comp.config is not found

Just updated/re-installed Sphinx and some other components and it no longer compiles. Was there anything missing in the 1.7 setup?

Looks like the setup did not actually install the components. Doing it manually has fixed it.

Can you please elaborate better about what happened and the solution? We are not aware of such issues in installers.

Sure: using TMSSubscriptionManager2.exe, updated Sphinx to 1.7 (it was installed before, so it un-installed the old version first, then I have selected the same folder and Ok'ed re-using the same folder). Build seemingly worked (I just left 2 Win platforms, because there's some issue with Android platform here, which I'm not using anyway), no errors reported. But TSphinxServer was not installed into Delphi 11.3 palette, causing the usual problems opening project forms with these components on them. I just opened the package manually and re-built / installed it in Delphi and the issue was gone.

I'll be eventually installing it in Delphi 12 anew, so I'll be able to tell if that works, later on...

Ok, thanks for the feedback. Indeed, if it happens next time, you have to please make sure that your IDE doesn't have any leftovers (uninstalled packages, folders in search path), and then if installation fails, please provide the full log files.

But even more important, from now on, try to install BIZ products using TMS Smart Setup. The existing installers will be deprecated in near future, so we won't work on them anymore.

Smart setup ended displaying an error. And has not updated status on-screen. But seemingly installed everything anyway.

As it has no prompt for the target location, it installs everything under the user profile. Can it be changed?

Which error?

I'm not sure what you mean by that.

It was you who chose the folder. Just uninstall everything and move the folder to one of your choice.

Looks like my email response did not make it here, re-sending:

[ERROR] Error running TTmsInstallRunner: Running failed: install tms.biz.aurelius tms.biz.bcl tms.biz.echo tms.biz.logging tms.biz.remotedb tms.biz.scripter tms.biz.sparkle tms.biz.sphinx tms.biz.xdata tms.flexcel.vcl tms.fnc.apptools tms.fnc.blox tms.fnc.chart tms.fnc.cloudpack tms.fnc.core tms.fnc.dashboardpack tms.fnc.excel.bridge tms.fnc.ganttchart tms.fnc.maps tms.fnc.uipack tms.fnc.websocket tms.fnc.wxpack tms.vcl.excel.bridge tms.vcl.uipack (ETmsRunner)

I did not try any one by one, because there are clearly dependencies and I’m not sure what depends on what.

See how it was still saying "Not installed" about all packages, even after it was in fact all installed.

Ok, I may have missed the folder selection, will need to redo it...

Please then send the Logs.zip file.

It installs everything under C:\Users\[current user name]\AppData\Local\TMS Setup\Products and there are no settings to change this that I can see. Is the .yaml file the only place? How can the destination folder be set for all packages?

Just uninstall and reinstall in the folder you want. It looks like you used the TMS Smart Setup installer (not the portable version), so the folder is asked during the install process.

Alternatively you can simply download the portable version and unzip it in the folder you prefer.

It looks like Flexcel installation is the culprit, so you can try again having it unselected.

Indeed FlexCel is not currently compiling for linux in smart setup, because we are studying to replace our own SKIA wrapper by the one that comes in D12 (Skia4Delphi). The problem is that Skia4Delphi is missing some functionality we need, so we are looking at it. A new FlexCel release with this fixed should be coming very soon.

And it looks like this smart setup does not install Web.Core - I see no selection in the GUI of this setup and then no folders, no sources, etc. after the installation. I'll try the old way.

Yes, TMS Web Core is not available in TMS Smart Setup yet.