Something went wrong

I have an app that uses a TWebGmaps component. This works great here on the office network.

When I ran it on a client network, The map briefly shows then I get a message 

Sorry! Something went wrong.

This page didn't load Google Maps correctly. See the JavaScript console for technical details.

I also tried on my notebook tethered to my phone connected via 4G and got the same. Connecting my note book to my office wi-fi and it all works.

Can you help?

Dave Craggs

Do you use a valid Google API key connected to a Google billing account?

I haven't enabled billing. But why would it work on my network, but not elsewhere?

Coupling to a billing account has become a requirement. Please ensure first this is setup correct.

Still doesn't explain why it works on the network here. 

Confused... :-(

This is under Google control|utmccn=(organic)|utmcmd=organic|utmctr=(not%20provided)&__utmv=-&__utmk=133900686&_ga=2.82712979.441611228.1570799245-442383749.1483615208#3-license

Apologies - worked out what was the actual problem.

I had restricted the key to specific IP Addresses.

Sorry for the confusion.

But not to do with billing!!