I am using a DBAdvgrid.latest version.

I want to save to csv , comma separated

This works but there is a blank first column ., all the other columns are correct and are as in the grid.

I do not want a blank first column .

How can I achieve this ?




 SaveDialog1.FileName := 'C:\ATLAST\MMSPOSTX.CSV';
  DeleteFile(SaveDialog1.FileName) ; // Delete prior file

I assume you have as first column a fixed column?
If so, set grid.SaveFixedCells = false

Thank you Bruno

I removed the grid I had and added a new grid (with no settings) and the code you supplied,

I now have a csv file without a blank first column