Runtime Error When ACT & LIC exists

For a whole week I can't install distribution of TMS Component Pack (VCL).
TMS technical support could not solve this problem. I'm very disappointed. :(
Constantly gives an error in the presence of files ACT and LIC in the directory "c:\Users\Documents\tmssoftware".
If they are missing , the installer is started.
I urgently need to fix the problem with the installer!

Error text:
"Runtime Error (at 146:7786) 
Access violation at address 014E5448. Read of address 43205345 "

1. Operation system reinstalled.
2. Administration permissions.
3. Windows 10 x64 Pro

I regret we have not found the reason for this error.  We have given numerous suggestions though.

1) In the first place, when there is a proper internet connection on the machine, this step with .ACT / .LIC file should be necessary at all. If something blocks the internet HTTP GET access from the installer, we suggested to use a (free) tool like fiddler to analyze it and fix it so the software can be directly activated instead of using files for offline install.

2) Try to put the .ACT / .LIC / SETUP.EXE file in a folder that doesn't belong to a Windows user account like a TEMP folder. It is not clear to what Windows user account the folder c:\Users\Documents\tmssoftware belongs, so it is not clear if there could be a permission issue.

Bingo! The experiment was conducted with the Internet on.
The effect is as follows:
1. If there are 3 files (lic, act and exe) in the "c:\Users\z\Documents\tmssoftware" directory, and I run exe from here - an error occurs.
2. If I copy this directory to another disk and run exe from here - an error occurs.
3. If I clear the "c:\Users\z\Documents\tmssoftware" directory and run exe from copy of this directory from another disk, then, bingo, everything worked!

Is the Internet connection required if i have exe, lic and act files?

An internet connection is not needed with the .ACT & .LIC files.

if so, then there is an error in the installer. 

There must be a problem with privileges on specific folders.

Which directories? This privileges are set by the system by default.

Access to userdocs is limited to the actual Windows user account owning it.

Bruno, thank you for the help!