Problems after upgrade to

Now I installed the latest update and when trying to compile my old project containing TAdvStringGridI get the following error:

[ILINK32 Error] Error: Unresolved external 'StrCmpLogicalW' referenced from C:\USERS\ZELJKO\DOCUMENTS\TMSSOFTWARE\TMS COMPONENT PACK\BUILDERXE2\TMSDXE2.LIB|AdvGrid

Tried on 2 of my computers with the same project and both failed. Project contains only TAdvStringGrid and no other component from TMS Component Pack. Other components are standard VCL.

Now I also tried some other projects containing TAdvStringGrid and the error is the same.

We're investigating this. The problem seems to be C++ specific

Can you try to add the following line in the main CPP file of your project to see if this helps:
#pragma link

That works. But anyway, fix would be appreciated.


Why is this issue not fixed yet? I still need to add thislib into my old projects containing TAdvStringGrid.

This issue was fixed in v6.9.1.1 or later

No it's not. I've installed latest update today and still it's not working.

And yet again, STILL NOT FIXED in TMS Component pack v7.0.0.0.

Clearly you don't really care if I report something, and personally, I'm tired of being ignored and wait for days for you to react and then to do nothing for months (this issue was reported on May, 7).

It's like in the previous topic:

God knows how long will you ignore the thread and then say something, and MAYBE fix it - Obviously, you didn't even bother to test components on C++ Builder before shipping. 

And finally now I've had it. With this kind of customer support I will not continue my subscription of TMS Component Pack once this one is expired. You clearly ship components while they are still in alpha state, with no (or minimal) testing and ignoring the customers.

I can do better then this.

Zeljko Kovacevic

This was retested and we cannot reproduce this here.
I can only suspect your setup is not clean. Check for old versions of AdvUtil.* that might be hanging around.

If a problem persists, try first if you can use these components in a new application. If this works and not in your app, please provide at least sufficient information to allow us to reproduce your problem here.