Possible to set keyboard type on column?

Hey folks,

We're just wondering how to set the KeyboardType (for mobile devices) to NumberPad for an etNumericEdit column.

We've tried the following, but with no success:

procedure TMainForm.gridGetCellEditorProperties(Sender: TObject; ACol,
  ARow: Integer; CellEditor: TFmxObject);
  TTMSFMXEdit(CellEditor).KeyboardType := TVirtualKeyboardType.NumberPad;

Any other method of changing the keyboard type for a specific column?

Thanks in advance!


Sorry - I forgot to include our current version and development environment:

IDE: Delphi Seattle (XE10) Update 1
TMSPack for Firemonkey Version:


We have tested this here and are able to set the keyboard type using the OnGetCellEditorProperties event. Are you experiencing difficulties?

Hi Pieter,

That's correct - we have the aforementioned code in the OnGetCellEditorProperties event, but when tapping on a field in the grid, the iPad shows the full keyboard.  I have assembled a small demo project that demonstrates this issue - is there some way I can send that to you for testing?

I'm testing with an iPad Air w/ iOS 9.2

Hi Pieter,

This issue may not be a TMS issue - I get the same behaviour if I add a regular TEdit to a form, then set the KeyboardType to "NumberPad" in the IDE.  Result:  iPad Air iOS 9.2 still shows the full keyboard - I will do some additional research on Delphi forums.


When setting it to NumberPad, we get the keyboard which has numbers at the top. It's not the numbers-only keyboard. I think the implementation in FireMonkey is for iPhone only.

Hi Pieter, you are correct - the iPad does not have an "all numbers only" pad as I was expecting.  My apologies for the confusion!