Popup form causes error when resizing

VSC WebCore v1.0.3230 / Win10 / Chrome Browser

Inside the main form I'm creating a popup form with border:= fbDialogSizeable. Moving the popup form is working, but when resizing it to a certain size (not reaching the main form border) the application is showing an error.

I wanted to test it also with border:= fbSizeable, but when open the popup form, I can't grab the border to resize it. Basically it has no visible border at all.

The same popup window with border:= fbSizeable

I have retested this with the demo Demo\Basic\MultiForm and opening a popup form with resizable browser but I cannot see a problem here.
What are you doing different from this demo?

Hi Bruno,

I got the the same error when popuping a form with the border set as fbDiaglogSizeable. I also tested MultiForm demo. The multiform demo is bit different since inside pupup form, in my case I created another form hosted on the first page sheet of pupup form.

So basically, this is code I used to test popup form:

newform := TForm3.CreateNew(procedure(AForm: TObject)
newform.Caption := 'Child form';
newform.Popup := true;
newform.Border := fbDialogSizeable;

Popup works, however, if I tried to resize the form by dragging the right-bottom corner, it shows an error saying "ResizeObserver loop limit exceeded" as you can see from pitcture I uploaded.

Another issue is : I checked the akRight (from Anchors) controls inside the popup form, to make sure they can maintain current position relative to an edge of its parent. However, if I resize the form, I did not see expected behavior of those controls, I am not sure if this issue is associated with above error...

Thanks, for your support in advance. To make it clear, I also have included my test file here test.zip (1.4 MB) for your reference. Any suggestion would be very helpful.

All the best,

Seems to be a browser issue.

We implemented a workaround.
This will be included in the next release.

Thanks Bruno. Looking forward to next release~~

I could not reproduce this error when using TMS Web Core with Lazarus. Didn't test it with delphi 10.3

I also noticed this anchor issue when trying to set anchor akRight, but wanted to decribe it in a separate ticket. The interesting thing is, that its working correctly when placing a control directly onto the form. When placing controls onto a TWebPanel or TWebGroupBox things are going wrong as Peter already decribed

As I mentioned, we implemented a fix. We will release it this week.
I propose to let this case rest till everyone had the chance to test the update with fix.

Sure, I thought some additional informations might be useful. In your anouncement to provide a fix it wasnt clear for me that is will cover both issues.

Any news about when the fix will be available?

Hi Ulrich, I have tested under TMS' latest version of TMS WEB core, and did not see that issue any more.

Hello Peter,

the issues are only in TMS Web Core VSC and NOT in the latest TMS Web Core

We schedule a release of an update of TMS WEB Core for VSC next wee which will be in sync with TMS WEB Core for Delphi with respect to framework code.

The latest version 1.0.3627 fixed it. Is there any system in the Web Core VSC version number to see which version of the Web Core for delphi comes with it?

The Delphi TMS WEB Core version isn't reflected at this moment in the VSC plugin.
At moment of a release of TMS WEB Core for VSC, it automatically takes the latest TMS WEB Core for Delphi state for the framework.