OpenMarkerInfoWindowHtml function not wor

Hi, I've been using the OpenMarkerInfoWindowHtml function to show popus info on my maps, and it worked great, until yesterday. Now this only works in the emulators, when I compile the exacly the same code of my app to iOS or Android and then click on the markers the popup info doesn't work, no popup apears. I don't know what's wrong.....

We are unable to reproduce this here. Which iOS version are you using and are you using the latest version of the TMS WebGMaps for FireMonkey?

Kind Regards, 

The events not function in iOS8..Check!


We have tested this here again but are still unable to reproduce this, please send us a sample that is able to reproduce this. Please also try out the marker click that is demonstrated in the demo, are you able to reproduce the issue with our demo?

Kind Regards, 

Hi Pieter,

thank you for your quick answer.

The problem still exits and is not only with the OpenMarkerInfoWindowHtml but also in almost all events and funtions, the map simply ignore the events.

In this Link there is a very simple project that run just great on Android and ios 7.1 , but in ios 8 the onMapclick event will not work, it's like the event doesn't exist.

In this sample there is also on the form create event some code the use the MapPanTo function , pointing to lisbon-Portugal, and once again the code won't work.

I've instalaled the last version of the webgmaps, but it's strange that in the object inspector of the maps component the version is

the ios version of my iphone is 8.1 (12B411) , it's an iphone 5 with 16 GB

We really need to get this to work, our app is ready to go to the store but not with this problems

Dear Mr. Rocha, 

Thank you for your sample, we have investigated this here and are still not able to reproduce this. Testing this here on an iPad with iOS 8.1 we are able to click on the map, and the address is added inside a marker. The correct place to call MapPanTo is not in the formcreate, but in the MapIdle event. It is unclear why the map click event is not triggered. Are you able to test this on a different device? Which SDK version are you using in Delphi to compile against?

Pieter Scheldeman2014-11-12 09:14:00

Hi Pieter

once again thank you for your great support,

In fact this issue is really strange, we have 2 mac's one with sdk 8.0 and another with sdk 8.1

in the mac with the 81. sdk we have Xcode Version 6.1 (6A1052d)

and in the mac with the 8.0 sdk we have xcode version 6.0.1(6A317)

In my development machine I have Windows 8.1 , embarcadero Xe7 professional and both the sdk and mac connections profiles.

I have tested with booth and the result is the same.

Hi Pieter,

Good News :)

I have made a compilation of my project using a connection profile to another mac width xcode 5.1 on it, and configure the SDK configuration on XE7 to use the 7.1 SDK and "voilá" it works.

So I think the problem must be something related with the use of an ios SDK above 7.1



It's a very strange issue. It could indeed be possible that it is related linking to an SDK above 7.1. Unfortunately linking to SDK iOS 8.0 and above is not supported in XE7.

Kind Regards,