Linker error with v1.4.5.0

Starting with a new PC, Win 7, 64-bit, fresh install of CodeGear RAD Studio XE Pro, and downloaded latest TMS Async 32, I get the following error when compiling program in C++ Builder XE:

[ILINK32 Error] Error: Unresolved external '__fastcall Vacomm::TVaCustomComm::SetDeviceName(const System::AnsiStringT<0>) referenced from...
The offending line is:
void __fastcall TMainForm::ComboBox1Change(TObject *Sender)
  (void) Sender;  //... Quiet compiler warning
  //... Configure the Serial port
  VaComm1->DeviceName = ComboBox1->Text;   //...  <--  This line generates error
  The function to populate the ComboBox is:
void __fastcall TMainForm::ComboBox1DropDown(TObject *Sender)
  TStringList* tslAvailablePorts = new TStringList();
  (void) Sender;  //... Quiet compiler warning
  //... Clear the existing List
  Any help would be appreciated. 

It's not immediately clear what is causing this.
SetDeviceName is defined as:

SetDeviceName(const System::UnicodeString Value);
It is not clear why it tried to find a function with AnsiString parameter.
Could try to cast the string to assign as UnicodeString?

I'm not exactly sure.  This is the same code that worked with earlier version ( of Async 32 and C++ Builder 2007 on Windows Vista 64 bit.

- To step around this, I created a new project, dropped in a new VaComm1 object, copied relevant lines from previous project.
Going back to C++ Builder 2007 / Vista is not an option...     :)

Sorry, but I have no idea on this. I cannot see a problem here. Again, can you make sure that you pass a UnicodeString type to SetDeviceName

Yes, typecasting the string worked:

 VaComm1->DeviceName = (UnicodeString) ComboBox1->Text;