Installation Error

We have very old legacy software that we have been asked to change.  This is several hundred pages of code that has worked fine for many years so a complete redo is not an option.  The program was created under Borland Delphi 6 Professional Update Pack 2 on Windows 2000 Professional Service Pack 4 with IntraWeb version 8.0.3.  We have TMS IntraWeb Component Pack, TMS Query and TMS Planner.  The software is being reinstalled on a newly formatted hard drive - this is a fresh install - no trial versions or previous versions of IntraWeb or TMS.  Delphi installs fine.  IntraWeb installs fine.  All TMS components refuse to install.  All give the same error:

"IW***.pas: Never-build package 'Intraweb_80_60' must be recompiled"

I have found the FAQ note on this, but it does not apply.  I distinctly remember this same error when we first purchased TMS many years ago.  It involved over a dozen emails to technical support before it was finally resolved.  It had nothing to do with our setup, but some off the wall interaction between IW and TMS.  I've looked everywhere to find our notes on this, but can't.  For the life of me, I can't remember what had to be done to get it to work.  Now we are faced with the same issue.  I've got to get this to work.  Does anyone have any ideas?

Additional Info:

TMS IntraWeb Component Pack is version 2.7.  All TMS software was purchased 4/10/2006.

Try to see if toggling the setting "Build control" between "Rebuild as needed" and "Explicit rebuild" under "Description" in the TMS IntraWeb Component Pack package files helps.

Hi Bruno:

You are the guy that helped me about seven years ago on this.  Unfortunately, I can't remember what we did to get it to work.  What I already did a few days ago was to open the TMS package I wanted to install, click Options (remember this is Delphi 6 Pro), go to Description, click "Explicit rebuild" and click OK.  I was then going to click Compile and then Install.  I get the error on compile.  I did this with the TMS Query component set.  With the TMS Planning set, I opened the .dpk file, clicked Options, went to Description, clicked "Explicit rebuild" and clicked OK.  I then went right to Install. Same error.

You will understand that I do not remember your specific case either and without any further details, there isn't much helpful I can say.

Here is some general information about the problem you experience:'%s'must_be_recompiled(Delphi)


I've already looked at all of those.  None apply.

This particular project was HUGE and the last major app we built with Delphi.  IntraWeb changed their install procedure I believe with this version.  They provided a custom installer.  There is source to many, but not all of the units.  We were, a few years earlier, one of the few organizations that had full source to all of IntraWeb.  We had to sign a notarized agreement with AtoZed.  That was for version 5.  We didn't carry that forward to version 6, 7 and 8, since we were then more worried about the future of Delphi than the future of IntraWeb.  I haven't kept up with things, so I have no idea what is going on today.  At any rate, the installer creates a LibD6 directory with the bpl and dcp files.  These are binary files.  There are no .dpk files.  In other words, the source code to the packages are not included.  When we ran into this problem, we went to TMS first who sent us to IntraWeb and IntraWeb sent us back to TMS.  I believe the underlying issue is that IntraWeb packages can never be recompiled since you are NOT given the source to do so, but your components were doing something that was triggering a recompile, which was not allowed.  I know it was you that fixed this, since IntraWeb would not budge an inch to change the situation.  I can't remember what you did, but nothing would work until that point.

If I recall, you and IntraWeb were going to work together so this would not happen if the future.  I think we were the one of your first customers to stumble on this.  But I never kept up with what was going on.  You fixed it, we finished the application and then we dumped Delphi.

Well, I'm not aware such issue happens with any of the latest IntraWeb versions 11,12 & 14 we support at this time.

Oh, I'm sure it doesn't.

We needed the version of IntraWeb we used because had some good features not in version 7.  You had just released your software for IntraWeb 8.0.3.  I'm guessing this issue was present for a brief period of time.  At any rate, you had me do something that fixed the problem and I was able to install all TMS components.  I can't remember what it was, but I need to do it again.

I can't upgrade everything to new versions just for a couple of days of work.  We used components from almost two dozen Delphi vendors in this app.  I'm sure most have gone out of business.

Is there anything you can think of that would fix this?  Do you still have archives of old versions of TMS?  I'm guessing you resolved this issue in the very next version of TMS. 

Sorry, other than the build control setting on both TMS packages & IntraWeb packages, I can't think of anything.
Unfortunately, we do not longer have all these old versions available.