Install/Build error

Just tried updating the Business libs (Win 10, Berlin Enterprise):

Core, Aurelius, Sparkle, XData, RemoteDB succeeded, Echo failed:

An error occurred during install:
Exception: Could not execute command line. Exit code: 1

    Deleting file "echo.vrc".
                  Embarcadero Delphi for Android compiler version 31.0
                  Copyright (c) 1983,2016 Embarcadero Technologies, Inc.
                C:\Program Files (x86)\Embarcadero\Studio\18.0\Bin\CodeGear.Delphi.Targets(405,5): error F2041: Read error on 'C:\Users\edward\Documents\tmssoftware\TMS Echo\packages\dberlin\Android\Debug\Echo.Server.o'
                Done Building Project "C:\Users\edward\Documents\tmssoftware\TMS Echo\packages\dberlin\echo.dproj" (Build target(s)) -- FAILED.
                Build FAILED.


I have a vague recollection of this happening before - but can't find how to resolve it.



Hello Ed,

We have received a couple of reports about this but users seem to have solved (or worked around it) and didn't report what happened. We were never able to reproduce this, and it simply looks like an issue with compiler generating and/or reading the compiled binary files.
I think what users have tried either of these options:

1.Simply uncheck Android platform when installing Echo (if you are not going to use it in Android of course);
2. Disable antivirus;
3. Delete all files under "C:\Users\edward\Documents\tmssoftware\TMS Echo\packages\dberlin\Android".
4. Manually compile the package from Delphi IDE (for Android platform, both Debug and Release configs)

Had to do 1)...

Manual uninstall, Disable AV, delete TMS Echo folder and try reinstall. Same thing.

I'll wait until I need it in Android to try again or do manual compile.