indexedDB Dataset Active and Open

Hi ,

been trying to use indexedDB dataset but are still not able to get a fully desirable result and stuck for a few days and need some guide here ,

(all below apply to indexedDB dataset)

1. found that := True is not equal to dataset.Open ?
2. when i did a destDataset.FieldDefs := sourceDataset.FieldDefs; 
    where sourceDataset is TWebClientDataset , i check at chrome console
    that the destDataset.FieldDefs existed with fields , but no matter how i tried
    to set dataset active to true or call open , it won't really active and show the message ,

   IndexedDB: Internal error, DoGetData entry with these conditions not possible.
   Can you please advice ?

3. i did the same above , instead of one line to assign the FieldDefs , i looping the 
    FieldDefs count and crearte the Fields line by line , at the end the result look simiar
    and when i tried to make a call to open / active to true to the dataset , it will threw ,

   IndexedDB: Internal error, DoGetData entry with these conditions not possible. 

I will really need to get this indexedDb Dataset work. please advice thanks.