how to solve issues about TTMSFNCGrid, TTMSFNCEdit (ImeMode)

###. TTMSFNCGrid in TMS Web Core

If the 'Colors' setting is applied after the 'HorzAlignment' setting, please review the error that the 'HorzAlignment' setting is treated as 'Default' as the 'gtaLeading' setting.

(Ex> grid.Columns[I].HorzAlignment := stSet.DATA[I].taHorzAlignment;)
(Ex> grid.Colors[ T, I+1] := $00CFCFCF;)

Require about how to express 'Strikethrough'.

###. TTMSFNCEdit in TMS Web Core


If the ImeMode setting is set other than imDontCare, an error occurs. Require about how to set ImeMode.

[Req.2] is solved.

For number 1, you are overriding the properties on cell level by setting the colors. You should also set the HorizontalAlignment:

grid.HorzAlignments[T, I+1] := gtaLeading;

How do I set the 'ReadOnly' property for only a specific column?

How do I set ImeMode for TTMSFNCEdit on TMS Web Core?
( This is Korea. For a specific 'TTMSFNCEdit', I want to set Korean input as default. )

You can use the OnGetCellReadOnly event

TTMSFNCEdit maps onto a HTML INPUT element in TMS WEB Core and ime-mode CSS attribute is deprecated and was never fully cross-browser supported, so we cannot expose this.

In the browser, the HTML INPUT should adopt the default IME mode the user has selected himself for the browser.