Hi, using our newly purchased TMS UI pack to compile older project with TMSGrid we are getting this error: Unable to find package import: GridPackDXE10.bpi. I replace the grid from the new version but I am still getting the same error. Has anybody solved this problem? Thanks.

Remove the dependency on this package file from your project. This referred to the old TMS Grid Pack package file while you now have the TMS VCL UI Pack package. So, it will depend now on TMSVCLUIPackPkgDXE10.bpi

Thanks a lot Bruno - that fixed it !

When I attempted this fix it generated an error unable to open file "vcl.baseimagecollection.obj". Does that mean I did not properly remove the dependency and properly attach the new TMSVCLUIPackPkgDXE11.lib , or is that likely its own problem and unrelated

Is this error when compiling your app or compiling TMSVCLUIPackPkgDXE11 ?
I'd rather suspect it is coming from your app as vcl.baseimagecollection is part of the VCL.

Thank you for the response, with that direction I have narrowed down the problem to being unrelated to the TMSVCL package and being related to another package that interacts with the VCL.