Form Policies aren't processed


im using the IW Security System with IntraWeb 14.0.52.
I connected the SecurityManager to the Datasources and can create Users and permissions on different forms.
When adding a policy, i see the changes in my table but the permissions are not granted.
I want to hide specific Menue entries for some Users.
i want to delete the Permission in the formpolicedialog (not at
runtime), i also get an error 'invalid Index' and the dataset isn't
First i thought, that the problem was the missing "ID" Field
in my dataset, so i added an Integer field with autoincrement but the
error remains.
I'm also using the Security Manager for VCL Applications. May there be a problem between both Components?
Are there any suggestions?
Thank you very much


We are not aware of any issues as you described in the TMS IW Security System.
Have you tried to compare your application with the demo application (included with the product download) to find out if you are doing something differently or something has been configured incorrectly?


i fixed the issue. I thought it would be ok to use an uniqidentifier field for UserID what actually wasnt. I tried the uniquidentifier because i alread ha a Datatable with users before i wanted to use the securitymanagement. I added an integer Field and I also changed the "Storage" in the SecurityManager-Permission tree from  "pstable" back to "psform".
Now it works fine.