FixInsight 2021.10 - Differences between the plugin and FixInsightCL?

Hello,

I have a problem with the FixInsightCL command line.

The problem is found both under Delphi 10.4.2 pro and under Delphi 11.2 Pro

Here is the command line I am running:

FixInsightCL.exe" --project="D:\Project\myProjec.dpr" --"output=D:\Results\FixInsight\myProject.csv" --libpath="C:\Program Files (x86)\Embarcadero\Studio\22.0\source" --unitscopes="Winapi;System.Win;Data.Win;Datasnap.Win;Web.Win;Soap.Win;Xml.Win;Bde;System;Xml;Data;Datasnap;Web;Soap;Vcl;Vcl.Imaging;Vcl.Touch;Vcl.Samples;Vcl.Shell" --csv

In the “.ficfg” file of my project, I have this defined:

< IgnoreFileNames > < Name > C:\Sources\externals\ < Name > C:\ComponentsPro\ < Name > C:\OpenSources\ < /IgnoreFileNames >

The other parameters of the “.ficfg” file are taken into account when executing the command line.

My problem and that the result took into account the files which should have been ignored!

The problem is not present in the plugin.

The plugin ignores the contents of the folders put in this tag.

Is this a bug, or does the command line work differently from the plugin?

I emailed support and got no response.

So, I post here, a zip containing, a project that reproduces the bug of folders that are not ignored despite their presence in the .ficfg file.

I call FixinsightCL from the .cmd located at the root of the zipped folder to show the problem.

I hope that TMS will find quickly, what causes problem with Delphi 10.4.2 and 11.2.
MyProjects.zip (28.3 KB)

With the contents of the zip file, I also tried the following way, but my list of folders to ignore is still not taken into account:

"C:\Program Files (x86)\FixInsight\FixInsightCL.exe" --project="C:\MyProjects\My Project\ProjectForFixinsight.dpr" --settings="C:\MyProjects\My Project\ProjectForFixinsight.ficfg" --output="C:\MyProjects\Logs FixInsight\ProjectForFixinsight.csv" --libpath="C:\Program Files (x86)\Embarcadero\Studio\21.0\source" --unitscopes="Winapi;System.Win;Data.Win;Datasnap.Win;Web.Win;Soap.Win;Xml.Win;Bde;System;Xml;Data;Datasnap;Web;Soap;Vcl;Vcl.Imaging;Vcl.Touch;Vcl.Samples;Vcl.Shell" --csv

for me it is a bug.