Facebook Login : Given URL is not allowed...

Hi !

I wrote a simple Windows application that can publish text and picture on a FaceBook Page, using your Delphi FMX Cloud Components.
This works fine for 8 months, until yesterday. Now, during authentication, the browser show this message :
"Given URL is not allowed by the Application configuration.: One or more of the given URLs is not allowed by the App's settings. It must match the Website URL or Canvas URL, or the domain must be a subdomain of one of the App's domains."

My FaceBook application has been configured conforming your suggested specificic and no modify has been made since creation :

App Domain : localhost

Wep Application 
Site Url : http://localhost

What's happening ? 
Thank you very much!

Fabrizio Colombini


The Facebook API has been going through some changes lately. It's possible that one of these changes is causing this issue.
Can you please have a look at this page (https://www.facebook.com/help/community/question/?id=542958419109491) and follow instructions on how to solve the issue?

If the problem persists, please provide a screenshot of your app configuration settings on the developers.facebook.com page so I can further investigate this issue.

Thank you for your support.

I alreay have visited this page, but i still have problem.
These are links to facebook app configuration screen-shot :


Thank you for investigate.

Fabrizio Colombini

From looking at the screenshots your settings seem to be correct.
Can you please enable logging for the TAdvFacebook control in your application and provide the LOG file (automatically created in the documents folder of your machine) after the issue has occurred?

  AdvFacebook1.Logging := true;
  AdvFacebook1.LogLevel := llDetail;


A follow up to this issue:
Can you please make sure the “Embedded browser OAuth login” is enabled in your app?

-          Go to: https://developers.facebook.com/apps
-          Select your app from the Apps dropdown.
-          Click on the “Settings” section
-          Click on the “Advanced” tab
-          Make sure the “Embedded browser OAuth login” switch is set to “YES”
-          Save changes

Thank you very much! You are right, problem solved setting  “Embedded browser OAuth login” switch to “YES”.

Best regards,

Fabrizio Colombini