Export to PDF errors on formula cells

I'm considering buying FLEXCEL and using the demo I tried exporting a file XLS to PDF.
The PDF is created successfully, but the content of some cells does not seem to be recalculated (when I opening this file in EXCEL, all is absolutly fine).
I tried in every way. using RECALC (TRUE), or by setting RecalcMode in every possible way but I did not have any change, the cells that require recalculation give error.
Since the particulars of these cells were related to sheets of XLS files that I did not want to convert to PDF, I also tried to export all sheets, but the result is the same.



Can you send me an example of the file you are trying to export to adrian@tmssoftware.com so I can take a look? In general recalculation should be straightforward, so I imagine it is some not supported feature, but it is hard to guess which without seeing the file. 

You might also try to run the demo: "75.Validate Recalc" in the API section and post or send me the results of pressing the "Validate Recalc" button if it reports something not supported.

Ok I'll send you the file.
I will also try the example for the recalculation, I had not tried it because I thought would serve only when references were relevant to other files!


I got the file and I am investigating it. It seems to be some trouble with the Intercept function, I'll let you know more when I finish.


There were 2 bugs in the recalculating engine, both related to array arguments in non array formulas. Both bugs have been fixed now, and the file you sent me now recalculates correctly in FlexCel.

The formulas that didn't calculate fine were S12, I95, J95 and K95, all in the sheet "calcoli". As you are only trying I can't sadly send you a fixed version, but you can try the rest of the functionality by pressing F2-F9-Enter in those cells to convert them to values. From what I see, the only other thing that you will miss is that the chart rendering engine in FlexCel doesn't draw trendlines, so you will not see those in the charts. The rest seems to be fine.

Thanks for your answer!
Sorry for the void post!