Existing WebApp Won't Run


I have something strange going on since installing

When I open the project it reports that a new version is available. I have done a complete uninstall and re-install but remains the same.

When I run the app from within the compiler the compile dialog stays open. It shows a successful compile but of 0 total lines.

When I build the project, I gut the same response of 0 total lines.

There is nothing in the projects TMSWeb folder.

If I create a new application, or compile a demo app all runs fine.

Any help would be greatly appreciated.



What version is reported from Help, About TMS WEB Core in the IDE?

Do you have such problematic project that you can send so we can inspect?

The help is reporting but when I go into Tools>Options>TMS Web>Options it is

You must still have old BPLs around on your system.

Verify via IDE, Install components, remove the TMS WEB Core packages.
Scan your hard disk for old packages TMSWEBCorePkgD*.bpl, TMSWEBCorePkgDED*.bpl, TMSWEBCorePkgLib*.bpl and delete all.
Do a new clean install.

Thanks. There were old bpl's remaining after uninstalling. I removed these before re-installing and the help about now shows but I still cannot compile or run my existing project - total lines 0 and no output file.

Have noticed something further now. Samples are not running either. If I
create a new project and run it, it works but as soon as I save it to
disk, it then won't run.

It is unclear what is causing this. We've not heard this problem report before.
Is there something specific to the folder structure where these demos & your project are?

Even if I save the project to a newly created folder d:\XXX it still doesn't do the compilatio.

In TMSWeb Options you are now using $(TMSWebDir) for folders. When I open the file llocation for these folders within your setup they are not found. Nor can I find this variable defined anywhere. Could this be the problem?

I have tried changing this folders to directly point to the underlying folder but unfortunately that makes no difference.

I have the same problem on both my laptop and development pc.

Do you have an antivirus installed / running?

Are you sure such software doesn't interfere?

Yes, I disabled it.

I need more information.
Is under Tools, Options, TMS Web, a valid setting for "Web Compiler". It should point to a DLL.

Can you email such project that isn't running so we can inspect and test this project here?
The Web Compiler is set as C:\Pair\TMS WEB Core RSXE12\Compiler\libpas2js.dll and the file exists.

I will email a project to you.

Rolling back to made no difference. I did notice that when I did a windows uninstall of that it did not remove the bpl & dcp files. Is it possible that the uninstall is also not removing some other files? I deleted these and all known Web Core folders before doing the install.


Scan your entire hard disk for TMSWEBCorePkgD*., TMSWEBCorePkgDED., TMSWEBCorePkgLib.* and delete all.
Restart your IDE and verify there is no trace of TMS WEB Core anymore, check
-Installed packages
-Tools, Options
-Help, About TMS WEB Core
should ALL be gone.

Delete registry key
HKCU\Software\tmssoftware\TMS WEB Core

After this, do a clean install by running the installer.

I have done all of this but still doesn't compile the javascript. I believe it may be to do with the $(TMSWebDir) in the various path settings for TMS Web Core Options. I cannot see the TMSWebDir variable in my environment settings.

$(TMSWebDir) value is defined by registry key

HKEY_CURRENT_USER\Software\tmssoftware\TMS WEB Core\InstallDir
This registry key should point to the folder where TMS WEB Core was installed. Check if with what you find in the registry, the paths configured under Tools, Options, TMS Web are correct.
This seems ok although since deleting the registry entry it is only showing web core products, not all the others.

What is in HKEY_CURRENT_USER\Software\tmssoftware\TMS WEB Core\InstallDir ?

Do you see in the folder
HKEY_CURRENT_USER\Software\tmssoftware\TMS WEB Core\InstallDir + \compiler  the file libpas2js.dll?
Registry entry for InstallDir is C:\Pair\TMS WEB Core RSXE12 Which is correct.
Entry for Pas2JSCompiler is $(TMSWebDir)\Compiler\libpas2js.dll.
C:\Pair\TMS WEB Core RSXE12\Compiler\libpas2js.dll is correct and file exists.
In TMSWeb Options however, if I click on the ... box for the Web Compiler. It does not open in C:\Pair\TMS WEB Core RSXE12\Compiler folder. Instead it opens the C:\Program Files (x86)\Embarcadero\Studio\20.0\bin folder.