Errors after update to

Since the update to version I get 2 errors and cant use FMX.GridExcelIO anymore:

[dccosx Error] FMX.UXlsOtherRecords.pas(29): E2217 Published field 'ObjId' not a class or interface type
[dccosx Error] FMX.UXlsOtherRecords.pas(30): E2217 Published field 'CmoId' not a class or interface type

Nothing changed in this code with the latest version. I can also not see any issue with using the TTMSFMXGridExcelIO component nor in the demo.

Do you see this issue in a new project?
Did you change something wrt default compiler settings in your IDE?

Yes, I can create a new project, and the moment I drop the component, I cant compile for OSX and get get that errors.


We have re-tested this here for the OSX32 target and couldn't reproduce this issue. Are you sure you are compiling against the latest version, no older version is installed on your system that could interfere with this? Are you linking/compiling against the latest macOS SDK?

MacOSX 10.12.2 sdk and it does the same.

However, adding public to the class and it compiles fine.

  TObjRecord = class(TBaseRecord)
    ObjId: word;
    CmoId: word;
    constructor Create(const aId: word; const aData: PArrayOfByte; const aDataSize: integer);override;


It's still unclear why this change should be made, because the files have already been added some versions ago. We'll investigate here what exactly is going wrong.

I had the same issue and fixed it also with the "public" in the class definition.


We have investigate and applied a fix, the next version will address this issue.

There is still NO fix. The latest version I downloaded today still has the same issue, so I again had to add public to the class.

We have investigated this here but it is still unclear why this error occurs. We have no compilation issues here, so there must be a specific setting on your IDE environment that requires this change. We have also meanwhile applied a fix that will be available in the next release.Pieter Scheldeman2017-05-11 11:57:54

I thought it was fixed already as stated 2 month ago, but it seems to be just fixed in the post :)

This class is the only class without any public, private or published, and is the only class causing issues.
And as you see in the thread here, there's another user reporting the same.
It does it also with a fresh 10.2 install, without any modification to any settings of the IDE.

As mentioned, we couldn't reproduce a problem here with the class definition without "public" identifier, but we have adapted it now anyway and the next release will have this adaption.