error: undefined reference to 'RandomBuffer'

Hi,

When compiling TMS Crypto 4.3.0.3 for Android 32, im getting this error:

[DCC Error] E2597 C:\Users\Developer\OneDrive\Documents\tmssoftware\TMS Cryptography Pack\Delphi104Sydney\Android\Release\MiscObj.o:MiscObj:function Miscobj::RandomBuffer(int, unsigned char*): error: undefined reference to 'RandomBuffer'
C:\Users\Developer\OneDrive\Documents\tmssoftware\TMS Cryptography Pack\Delphi104Sydney\Android\Release\AESObj.o:AESObj:function Aesobj::RandomBuffer(int, unsigned char*): error: undefined reference to 'RandomBuffer'
C:\Users\Developer\OneDrive\Documents\tmssoftware\TMS Cryptography Pack\libAndroid/libTMSCPLib.a(aes_mode.o):..\cryptobibGIT\aes_mode.c:function AES_EncryptFile: error: undefined reference to 'RandomUBuffer'
C:\Users\Developer\OneDrive\Documents\tmssoftware\TMS Cryptography Pack\libAndroid/libTMSCPLib.a(aes_mode.o):..\cryptobibGIT\aes_mode.c:function AES_GCM_EncryptFile_IVIn: error: undefined reference to 'RandomUBuffer'
C:\Users\Developer\OneDrive\Documents\tmssoftware\TMS Cryptography Pack\libAndroid/libTMSCPLib.a(aes_mode.o):..\cryptobibGIT\aes_mode.c:function AES_GCM_EncryptString_IVIn: error: undefined reference to 'RandomUBuffer'
C:\Users\Developer\OneDrive\Documents\tmssoftware\TMS Cryptography Pack\libAndroid/libTMSCPLib.a(aes_mode.o):..\cryptobibGIT\aes_mode.c:function AES_GCM_EncryptBinaryBuffer_IVIn: error: undefined reference to 'RandomUBuffer'
C:\Users\Developer\OneDrive\Documents\tmssoftware\TMS Cryptography Pack\libAndroid/libTMSCPLib.a(elt_rep.o):..\cryptobibGIT\elt_rep.c:function Rand_intbase32: error: undefined reference to 'RandomBuffer'

Add LibAndroid and TMS Cryptography Pack to my project search path

Reinstalled previous version of Crypto Pack 4.3.0.2 and successfully could compile on Android 32 Bits.

The version 4.3.0.3 cant be compiled for Android 32 bits. Meanwhile this error is fixed i did two installation one with previous Crypto Pack for compiling Android 32 bits and the new version for compiling Android 64 bits. Hope this get resolved soon, just bought this component

Thank you for reporting this bug, I will try to reproduce it and then fix it.

Best regards,
Marion

Hi Marion,

Thanks for letting us know!

Regards,
Aldo Victori√°

The issue is fixed in 4.3.0.4 version!
Best regards,
Marion