Error in tmsfmxricheditor

I have found a problem in the tmsfmxricheditor component - by accident. I have tried it on the new tmsfmxricheditor (but in older versions of delphi and tmsfmxricheditor and it doesn't do it.) It causes the program to hang and you have to crash it to get out. Type in some text, then click somewhere in that text and drag the mouse backwards to highlight the text, then click again and drag the mouse forward to highlight text, continue doing this a few times, maybe add some more text, and then click at the end of the text, and it will hang the component. The app brings up not responding.... Every time - a variable number of clicks, and drags are required but it always does it. Also, If you right mouse click on the text and don't choose anything then left click the cursor changes to a hand, even if you've set the cursor to be a beam.
There's something for you to trial and hopefully fix while I go off to bed (soon) as I'm in NZ. :)

Double post.
Reported to other post that this was traced & solved.