Error in SearchPath of LibOptions?

Hello everybody,

I just bought TMS Scripter Studio (5.1). When I run project ScriptIDE from the samples and I open 'newversion.psc' and I run it the following error dialog appears:
Error at line 1: INTERNAL ERROR
Library 'Versionutils' not found
I looked at the properties 'libOptions' of TatPascalScripter: In the SearchPath $(CURDIR) and $(APPDIR) are defined and also the property 'UseScriptFiles' is TRUE. The file 'VersionUtils.psc' is also in the same directory as 'newversion.psc'.
I am using DELPHI XE2.
Can you inform me if this is a bug in scripter studio or am I doing something wrong?
Thanks in advance.


in search path you must have the directory which holds the versionutils.psc file. $(CURDIR) and $(APPDIR) are the current and executable directory respectively, and probably they are not the same directory as the one having versionutils.psc file.


I copied the versionutils file to same directory as the exe file and it worked.
I assumed the $(CURDIR) meant the same directory as the main (newversion).psc file.
Beginners mistake :)
Again, thanks for the prompt answer.