Dropbox Error 400

I have an Android app that uses Dropbox, OneDrive and Google drive.  Under XE8 and cloud components v2.3.1.4 all worked properly.
I've recompiled the app under Delphi Berlin using the newest Cloud component suite v3.2.5.0 (the old version of the cloud components won't build in Berlin) but none of the three work anymore.

eg. When trying to connect to Dropbox I get a Dropbox error (400).

I've tried the Android cloud storage demo with Dropbox. I also get a Dropbox error (400) in the demo app.
Any idea why this is happening?


I have not been able to reproduce this issue.

Can you please specify the following information so I can further investigate this?
- Which version of Delphi Berlin are you using (Default, Update1 or Update 2)?
- Which version of Android are you using? The minimum required version is v4.4.
- An exact description of how the issue can be reproduced with the CloudStorageDemo.
- Is the problem also visible on Windows?

-I was using Delphi 10.1 (default), but then loaded Update2 with the same results.
-Android Marshmallow 6.0.1
entered my dropbox appkey and secret into ADDIDS.INC and compiled
CloudStorageDemo for android.  It downloaded to my Samsung Galaxy S2
model SM-T710 tablet and ran.  I selected DropBox, then the Connect menu
item.  The error 400 then appears.
I tried 32bit app target for Windows as well and it came up with the same error.

The error shown is;

It seems the app you were using submitted a bad request.  If you would like to report this error to the app's developer, include the information below.

Invalid redirect_uri.  It must exactly match one of the redirect URI's you've pre-configured for your app (including the path).

Can you please make sure you have correctly assigned the App.CallbackURL property with a value identical to the one added in the DropBox console?
Detailed instructions can be found here: http://www.tmssoftware.com/site/cloudkey.asp#DropBox

The redirect URI's were not set up.  Things have changed slightly since I first developed the app 2 years ago.
I also fixed the Google Drive issue by enabling the external browser as suggested in the latest documentation.
All working again.  Thanks.