Drag and Drop row on grid doesn't work

I want to use drag and drop for entire row rearrangement on a TAdvStringGrid. I have read the documentation and enabled the following properties to "true".


Drag and drop still doesn't work for me. It seems that drag operation starts (even the insert cursor appears on the grid) but I cant drop the rows. Windows cursor has the default "cancel-type" icon and when I release the mouse, the drop doesn't work.

I have set Allow:= true on all Ole corresponding event to allow the drop in a any case. Still doesn't work for me.

Is there something I am missing? If I use fmtClipboard copy (to use drag and drop to copy rows) it works, but I cant use drag and drop to rearrange rows.

Is there any other property that may prevent this operation?

Did you have a look at demo Demo\AdvStringGrid\Asg28, first tab that demonstrates row reordering via drag & drop?

I looked on the example. I have set OLEAcceptText to true (the grid need some OLEAccept type in order for row drag-and-drop to work). The problem is that every time I drag and drop a row in order to rearrange it, the target row becomes blank (all cells get empty).