DBPlanner - Last day of the month problem

Hello all,

We have a strange issue where the DBPlanner will not show items that are for the last day of any month.  Anyone else come across this.  For example this month (May) it will show correct for the 30th but not the 31st.  1st of June would then show correctly too.  We originally identified this problem last February and thought it was a leap year bug but no it happens for the last day of every month.

We have installed the latest TMS Component pack for Delphi 7 and the bug still persists.



In what mode is the Planner? What DBxxxSource is it bound to? Other relevant information?
Please provide us with sufficient information to allow us to understand & reproduce the problem here.

Thanks for the reply.  We have solved it.  The problem was within our own source code.  We had a query that pulled the records for the start and end of month.  The end of month was being formatted yyyy-mm-dd but it should have been formatted this way 'yyyy-mm-dd hh-mm-ss'.  That solved it. The developer got a clip round the ear!



This thread can now be closed.