Could not load SQlite library "sqlite3.dll"

I've been using aurelius with sqlite3.dll (32 bit) with sucessfull on my aplication that is 32 bit too.
Now I needed build my application with 64 bit and got a error "Could not load SQlite library "sqlite3.dll""
I downloaded from sqlite site the 64 bit version of sqlite3.dll and I got the same error. What can I do to fix this? thank you.

There isn't much more you can do, just use the correct dll. Have you tried put the sqlite3.dll in the same directory as your executable? Maybe it is still trying to load the 32-bit version.

Yes I Have. I downloaded from oficial sqlite website and put them at correct folder

32 bit

64 bit

I reproduced this on the GettingStarted sample from demo folder of aurelius.

Below we have the link with sources, bin and sqlite dlls (32 e 64 bits)!AgEe_WncLIrmtg1QoA-bayeP6fHj

Thank you

I don't know what you did.

Indeed, in your file, it doesn't work, but because your dll is not correct.
After I downloaded the dll from SQLite site:, it worked fine. 
Here is the direct link I used:

My apologies Wagner, you're right. I downloaded again this dll e now it works. I think the file that I used probably was damaged.

Thank you.