Confirming major problem in TMSFMXRICHEDITOR

v3.7.6. I have now confirmed this to be a major problem that crashes my program. I have since run the RichEditorSpellCheckDemo.exe app supplied with the latest version. You type in some text, then left click on the text to highlight part of it, and it freezes. (not responding.....) I would really appreciate a reply to this and hopefully a fix, as it's causing many hassles for my clients. Thank you.

Do you have more details? Exact steps? Delphi version? Operating system? Text entered?
I cannot reproduce this.

Hi Bruno, I am running Windows 10 (but it does it in my MAC version as well), Delphi 10.4 Version 27.0.37889.9797. Compiling in win64 and MACOS64. It doesn't matter what text I type in but you click and drag backwards and forwards a few times (although it sometimes happens immediately), and if it still doesn't freeze, you enter some more text, then left click at the end of where you've typed and it will freeze. Thank you for any help you can give. I'm using TMSFMXRICHEDITOR only so I can use the TMSSpellchecker as well, there is just plain text, no formatted text goes in.

I cannot reproduce this with the latest version.

Try highlighting a few times then click the space bar and add some more text then try highlighting again?

Are you using the same richeditor as me?

I have compiled the Richeditor spell check demo as well and it still does it using Delphi 10.3.3

Hi again Bruno. In you example that you couldn't recreate the error, you didn't click at the end of the sentence after highlighting a few times, and use the space bar and then try and add more text and then try highlighting again. It definitely fails. In my system anyway using Delphi 10.3.3 and also Delphi 10.4.

I have just found out that it doesn't appear to have a problem when you press enter a couple of times so there is a blank line after the text. It only does it if you type some text without adding an extra line or two below.
In the english text you added there are a couple of blank lines at the end so it doesn't cause an error.

So at least I know now how to stop the freezing from happening.

A space at the end of the line is essential to reproduce.
We could now find & fix this issue. The next update will address this.

Hi Bruno,

Yes, I worked out in the end it was a space at the end that caused this.

It was only found by accident and was reported a few times by my clients and I just assumed it was an issue at their end. :blush:

To fix it in the meantime, I just added a chr(13) at the end of the memo automatically when adding or editing the richeditor.

Glad you could find it and will fix it now, I was beginning to think it was just something at my end that was causing it..

Ngā Mihi

Kind Regards,



p. +64 3 4672888 or +64 274861444