CloudKit CloudDataSetDemo FMX

I have the CloudDataSetDemo VCL demo working.  I also have the CloudDataSetDemo Google Datastore working, but I cannot get the web authentication screen to come up for CloudKit on FMX for Windows.

Can you try it on your end?

I have the settings the same in VCL and FMX.


Which version of Delphi are you using?
Please note that for Delphi versions prior to XE 8, the Chromium browser is required to display the web authentication screen on Windows.
Instructions for Chromium can be found here:

Seattle and as stated it does show the browser for the VCL version.  It also shows the browser for FMX when using the "Google DataStore" radio in the demo.  It isn't getting the redirectURL from the json the same way as VCL.  I've tried debugging it.  I've even put the same ini for the tokens that are valid for the VCL version in my FMX project and it still doesn't work.  I also have the same issue when using the iOS FMX demo on my phone.  No browser to authenticate.

Are you sure you're using a correct CloudKit API key?
If so, can you enable logging on the component and send us by email the log file so we can inspect what is happening?

Email sent with demo projects.  VCL works.  FMX does not.

We'll investigate.