Hi, there is weird behavior of Flexcelreport with <#Row Height(Autofit)>
and default Height of Row.

In Preview everything looks OK, but after export to Excel the Row Height is unchanged

When I change Height of the line in template, everything looks OK


This is expected, and happens because even when FlexCel calculates the row height, when you open the file in Excel, Excel will re-calculate the row height if it is automatic. And Excel doesn't autofit merged cells (FlexCel does, but Excel doesn't). So yes, FlexCel autofits the row, but as soon as you open the file in Excel, Excel will bring it back to the wrong value.

The fix is simple: Set the row to not have automatic height, so Excel won't try to re-autofit it.

You can do this in 2 ways:
1. The simplest one, in the template just make the row a tip bigger, enough for it to not be the default size. This will turn off the row autofit, and the row will be fixed size.
2. If you prefer to set FlexCel so it marks the rows it autofits as fixes (to avoid Excel recalculating them), you can use:

and set the second parameter to "fixed".

Just remember that the problem is because of the merged cell you have there (even if it is merged in columns, not rows). For non merged cells you don't need to care much about this.

You can read more about autofitting merged cells here:

Hi, thanks for reply,
didn't know that.

Your solution 2 works as expected, thanks for advice