Assigning parent property to the "TTMSFNCWebBrowser" control freezes up code execution

When dynamically creating the "TTMSFNCWebBrowser" on the main form's "OnCreate" event, the code execution works 100% when targeting the Android platform. However, when trying to target Windows 32/64, the application freezes up. When setting a breakpoint and stepping through the code, as soon as you step over the code that assigns the parent property of the control, the execution just freezes. No error messages or anything is produced in the IDE. The cursor just never returns to execute the next line of code while stepping through the code.

Here is a code snippet:

MyTMSFNCWebBrowser := TTMSFNCWebBrowser.Create(nil);
MyTMSFNCWebBrowser.Parent := tabBrowser; //-> Execution freezes when targeting windows.
MyTMSFNCWebBrowser.Align := TAlignLayout.Client;
MyTMSFNCWebBrowser.URL := '';

It works 100% when targeting the Android platform.

Any suggestions?

Please add an owner:

MyTMSFNCWebBrowser := TTMSFNCWebBrowser.Create(Self);

It still doesn't work. There seems to be something else going on.

I decided to test the component again during design time, but instead of getting the "Chromium Successfully Initialized" message, it now shows blank result within the control. I get the same result whether I'm targeting the VCL framework or the FMX framework.

Directly after the control is dropped onto the form, I now also get an "Access violation at address 5005FC74 in module 'rtl270.bpl'. Read of address FFFFFFFD", then the entire IDE hangs.

This use to work when I dropped the control directly onto the form during design time, seeing the success message that Chromium has been successfully initialized. Now, on both type of frameworks, I encounter this issue that stopped working during design time as well as runtime.

What could have caused this control to stop working entirely, causing all of these issues??

The only change that took place within the IDE between the last state of the control working and now producing these issues, was the installation of the SDK's for "iPhoneSimulator 14.4" & "iPhoneOS 14.4".

I can't see how this would have impacted the "TTMSFNCWebBrowser" control to start producing these errors though.

Any suggestions?


Adding iOS SDKs should not have effect on the browser. We have tested the latest state here and couldn't reproduce the issue you are experiencing:

Did you install the webview evergreen runtime?

Runs fine for me with this code :slight_smile:

		FWebBrowser := TTMSFNCWebBrowser.Create(self);
		with FWebBrowser do
				parent := self;
				Align := TAlignLayout.Client;