AdvMemoSpellChecker AdvMemo Demo10


I'm trying to use ADVMemoSpellChecker to add spell checking to an AdvMemo of dbADVMemo. But I have not been able to figure out how to get it to work. The website says that Demo 10 in the AdvMemo demos demonstrates this, but there is no documentation of Demo 10 in the manual. 

When I run Demo 10 it does not seem to function. When I type a misspelled word in the memo there is nothing to indicate that the word is misspelled or offer anytime of correction. What am I missing? 


I cannot see an issue here with demo 10.
When starting it and typing a misspelled word, it shows the erratic word:

I didn't the see red squiggly line when I typed a misspelled word, like "teh" instead of "the". 

Turns out the problem was Delphi was linking to the firemonkey components instead of the VCL components. For instance when I ctrl + click on TMSSpellCheck in the uses section of ADVMemoSpellCheck it opened FMX.TMSSpellCheck instead of TMSSpellCheck. I removed the references to the paths of the firemonkey components from Tools > Options > Environment Options > Delphi Options > Library > Library path. Then voila, it worked!

Now the issue I'm experiencing is when I change the WordWrap property of the AdvMemo from wwNone to wwClientWidth the red squiggly line no longer appears. 

Error underlining is a line per line feature and unfortunately , it is not supported in word wrap mode.
TAdvMemo is designed as editor for programmers code. If you need more a text editor, we'd suggest to have a look at TAdvRichEditor