Activate / Deactivate column filter in TMS FNC GRid


After I activate DropDown filtering, if I want to deactivate them
Options.Filtering.DropDown := False,
Check Boxes is still visible and somtime generates AV.

Did you also clear the filter? TMSFNCGrid1.RemoveFilters;

I call TMSFNCGrid1.RemoveFilters

After that, data are not filtered, but check boxes in the header row is still visible and functional

Can you post a sample? (15.4 KB)

Please call TMSFNCGrid1.Options.Filtering.DropDown := False; to remove the buttons to show the filter dropdown.

In the sample that I provided you, that instruction is called at line 47.

Can you call TMSFNCGrid1.RemoveAllCells; as well? When switching a feature that impacts the cells, the cells need to be updated. As the grid dynamically re-uses the cells, it could be possible that the filter dropdown icon is still active. This is done for performance reasons. Using the above code should fix the issue.