install error

Failure message on installation completion, logfile shows the following:

Embarcadero Delphi for Win64 compiler version 35.0 (TaskId:49)
  Copyright (c) 1983,2022 Embarcadero Technologies, Inc. (TaskId:49)
AdvTouchKeyboard.pas(538): error E2213: Bad packaged unit format: C:\Users\Public\Documents\Embarcadero\Studio\22.0\Dcp\TMSVCLUIPackPkgDXE14.dcp.AdvStyleIF - Expected version: 35.0, Windows Unicode(x64) Found version: 35.0, Windows Unicode(x86) [D:\TMS VCL UI Pack\TMSVCLUIPackPkgExDXE14.dproj]
  The command exited with code 1. (TaskId:49)
Done executing task "DCC" -- FAILED. (TaskId:49)
Done building target "_PasCoreCompile" in project "TMSVCLUIPackPkgExDXE14.dproj" -- FAILED.: (TargetId:37)
Done Building Project "D:\TMS VCL UI Pack\TMSVCLUIPackPkgExDXE14.dproj" (Build target(s)) -- FAILED.

(full log available if required).

Installing to D2007, D10.1, and D11.3 CE


Looks like an IDE Library path config problem.
Please check your Win32 and Win64 library paths and ensure the output folders are set to different folders.

This was an automatic, not a manual, install so the paths are set by the installer? I checked after installation and the 64bit library path contained the VCL UI Pack 64bit directory so had been added correctly.

I have now installed on a second system, with the exact same error. I then uninstalled and tried the installation (my previous VCL UI Pack installation was a few versions lower) - this produced the same error.

What effect the error is having I can't determine - the AdvTouchKeyboard gets installed and appears to be working OK.

Maybe from previous usages, your compiling of apps produced 32bit DCU files in a directory that is part of your Win64 library path.
So, please check all your library paths and check if there are no leftover files like AdvTouchKeyboard.* from compiling things previously.

I couldn't find any such instances. I've nver actually used AdvTouchKeyboard component so didn't expect to find anything.

TMSVCLUIPackPkgDXE14 and TMSVCLUIPackPkgExDXE14 compile and install into D11.3 CE without error when I do so manually so I don't think we need to spend any more time trying to track down the error when using the installer.