10.3.3 Rio Installation Failure

I'm having to reinstall everything so I'm trying to get up to date on all my TMS software. I am building with IW15 as target.

I've run rsvars.bat as appropriate. I've made TMSDEFS140.INC TMSDEFS.INC. When I run MSBUILD on TSSCoreDXE12.dproj. I get 4 errors.

1) E2003: Undeclared identifier 'VarArrayOf'
2) E2001: Ordinal type required
3) E2010: Incompatible types: 'Integer' and 'string'
4) F2063: Could not compile used unit 'uSecControl.pas'

I ran a search on my entire system looking for uSecControl.pas and can't find it anywhere.

This is not critical at this time as the application I need to work on doesn't use this functionality but I'd like to get it working for future possiblity.



I think I may have figured out what is wrong but want to make sure.

The TMSDEFS140.INC does not have a section for VER330. I copied this section from and IW package and it now compiles fine.

It also appears, although not completely clear from the documentation that TMS VCL Security System and TMS IntraWeb Security System cannot both be installed.


The TMSDEFS140.INC file should indeed contain a section for VER330. Thank you for notifying the issue was resolved.

Both TMS VCL Security System and TMS IntraWeb Security System can be installed simultaneously but it will require some manual preparation:
- Make sure to first install TMS VCL Security System
- Make sure all references to TSSCore package from TMS IntraWeb Security System are pointing to the TMS VCL Security System package and/or units.
- Only install the IWxxTSSUIDXX package from the TMS IntraWeb Security System

Thanks for the quick update.

I suggest you might add a note in the install instructions that if you are using both VCL and IW Security that you should install VCL first and skip "msbuild TSSCoreDxx.dproj"

We'll add a note in the install.txt with instructions when using both the VCL and IW version.