tmsfmxcloudboxnetdrive login form

Thanks Bart for your support

Happy to help!

Hi Bart, the problem was not solved, I tried the new file and now I get the following error , if I comment the line the project compiles, but exactly in the upload function now I get this error

Hi Camacho,

There was indeed still a possible issue with Upload on mobile platforms.
This has now been fixed and an incremental source update was provided by email.

Thanks Bart, it works now

Thank you for confirming the issue was resolved.
The fix will also be included with the next release of TMS FMX Cloud Pack.

Hi Bart, I was doing tests in my application and I just detected that the component has other errors, the file is loaded, but it is loaded in the root, it does not respect the folder that you are indicating in the Storage.Upload method (cifolderOS, fn), additionally I am not sure if the Storage.SearchList (folder, false, nil); function is working correctly, this is the code I use

if Storage.Connect then

 folder:=Storage.SearchList(carpeta, false, nil);

 if folder.Count>0 then
     cifolder:= folder.Items[0]

 if cifolder=nil then
      MessageDlg('An error ocurred , the cloud folder not found , try again', TMsgDlgType.mtInformation, [TMsgDlgBtn.mbOK], 0);
      {$IFDEF IOS}

 folderOS:=Storage.SearchList('OS'+inttostr(MD_Gral.MyQry_SoluHelpDesk.FieldByName('ahelp').value), false, nil);

 if folderOS.Count>0 then
     cifolderOS:= folderOS.Items[0]

 if cifolderOS=nil then
     MessageDlg('An error ocurred , it was not possible to create the service order file  in the cloud , try again', TMsgDlgType.mtInformation, [TMsgDlgBtn.mbOK], 0);
     {$IFDEF IOS}

 for i := Low(rutas) to High(rutas) do
        fn := rutas[i].ruta;

           ci :=Storage.Upload(cifolderOS,fn);

           if Assigned(ci) then
              md_gral.MyQry_LinkHelp.fieldbyname('link').value:=(ci as TBoxNetItem).getShare;

Can you help me?


I have not been able to reproduce these issues:

  • Uploading a file into a subfolder is working when tested here.
    Does the issue happen for any subfolder or only specific subfolders?

  • The SearchList call returns all objects matching the Query string. Can you please describe exactly what is going wrong with the SearchList?

Hello Bart, the problem occurs in any subfolder, the problem with the searchlist is that it returns a value even though the folder does not exist and other times it cannot find the folder indicated, in my folder structure there are no files with the same name, this is the structure I am creating

------------ OS1983(Folder)
---------------------- File1
---------------------- File2
---------------------- File3
------------ OS1984(Folder)

I tell you that this code worked perfectly with the previous version of the component


Uploading in subfolders is working as expected when tested here in the CloudStorageDemo.
I also haven't noticed any issues with the SearchList call. There haven't been any changes in this area of the component so I'm not sure what could be causing this.
On which platform(s) can you see the issue?

If the problem persists, can you please provide a ready to run sample project so I can further investigate this?

Hi Bart, in this link you can download the example, the component does not work on any platform

how to use it?
1.- fill in your account information and box folder.
2.- press the connect button, log into the account
3.-press the select button to select the image
4.-press the upload button to upload the file

Thank you

Hi Camacho,

We are investigating this issue and will report back as soon as possible.

The issue has now been fixed.
This will also require a change in your application code.

Please change the following lines:

     cifolder:= nil;

     if folder.Count>0 then
         cifolder := folder.Items[0]


     cifolder:= TBoxNetItem.Create(nil);

     if folder.Count>0 then

The update will be available with the next release of TMS FMX Cloud Pack.

Thanks Bart any estimated release date ?, Can you send me an incremental file?

Hi Camacho,

The target for the next release is early next week.
You can request an incremental source update by sending an email to requesting the update.

Hi Bart, I just received the file and tested the component, I realize that you are still having problems in the searchlist method (really this already seems like a bad joke), you can try it with the same example that I sent you


Hi Camacho,

I'm unable to reproduce an issue with the SearchList method in the latest update.
Can you please make sure you made the suggested changes in your example from one of my previous posts?

If the problem persists, please explain exactly what is going wrong so I can further investigate this.

Hi Bart, the suggested changes were made, please see the video , the searchlist method returns anything, you can see the OS58 folder does not exist and the method is returning this japanese.xml file to me, therefore the file is not loaded in the correct folder


I'm not sure what is causing this issue on your side. The sample you provided is working as expected when tested here.
Can you please provide a log file so I can see what is happening in more detail?
To enable logging:

  TMSFMXCloudBoxNetDrive1.Logging := True;
  TMSFMXCloudBoxNetDrive1.LogLevel := llDetail;

The log file is automatically generated in the machine's Documents folder.

ok, I sent you the log by message