TMS FNC WX pack - barcode component not working under Windows 7

Windows 7
Delphi XE7 Pro
Browser: Chrome

Hi, I've successfully installed the Trial version of TMS FNC WX pack v 1.5.1.1 - ("TMSFNCWXPackXE7.zip" file) for Delphi XE7 to test it and see if it fits my needs. I am interested in the Camera and Barcode components.

However, I am unable to run some, if not all the demo examples provided.

It appears that the Trial version is crippled due to non-supported software on my system. I am running windows 7. And it appears that the trial components are phoning home every time I run the app and since it can't find Edge, it disables the functionalities of these components.

How can I test these TMS components?

This question does not belong to Miletus for JavaScript/TypeScript but to TMS FNC WX Pack.

It is a prerequisite for TMS FNC WX Pack that you have the Edge Chromium browser & engine installed in Windows.
See: TMS Software | TMS Edge Chromium support

I can only start new topics at this main page, https://support.tmssoftware.com/

And, once I do, the Category is locked to 'Miletus for javascript typescript)'. I can't change it to FNC WX or anything else.

It is because the support center write permissions is for customers with an active license and it is read-only for other users (except Miletus for JavaScript/TypeScript at this moment).

Okay. The only officially licensed/registered product I have of yours is the TMS Pack for Firemonkey v3.0.1.0, purchased back in 2015, as seen in the Delphi XE7 startup, screen copy, below, in case you need that info.

Did the instructions to have a proper Edge Chromium webview setup at:
https://www.tmssoftware.com/site/edgechromium.asp
help?

I gave it a quick look but I haven't tried it just yet. I am trying to get other things sorted out on this system before I start that. I will let you know later today.

I am interested in purchasing it for the Barcode and Camera features for my mobile devices (mainly my Galaxy S10+ smartphone, Android 10) to scan regular barcodes and also a QR code generator and decoder project) and I want to be able to use these two components under windows and android. If I can get a bare-bones test app working in both, then I want to make the purchase--though, I will most likely purchase.

I am downloading and installing Edge, now..

I have installed Edge and no longer receive those error messages. However, I am having trouble obtaining the results for the barcodes/qrcodes.

The demo 'fnc_wx_barcode.dproj' does not compile, and gives me the message:

File not found: 'C:\Users. . .\AppData\Local\tmssoftware\trial\TMSFNCWXPack RSXE7\Demos\FMX\BarcodeDecoder\FMX.Memo.Types.dcu'

The FMX.Memo.Types is in the Uses section but can't find it's ".dcu" file, so will not compile.

And in the TMS FNC WX Barcode Demo it will compile without error, but when I type anything, no barcode and no qrcode or any code will show up in the image. The image is blank.

image

Update..

After adding the 'WebView2Loader_x86.dll' file to \system32 folder, the TMS FNC WX Barcode Demo is now working.

image

Update..

However, the fnc_wx_barcode.dproj is still not compiling for the same reasons mentioned, (..\tmssoftware\trial\TMSFNCWXPackRSXE7\Demos\FMX\BarcodeDecoder\FMX.Memo.Types.dcu'), including the following pre-compile step, below are compiler errors.

image

image

image

I suspect this is because the FMX demo was built with a newer Delphi version and these are properties that didn't exist yet in XE7. Try to ignore these property errors, save the form file & compile.

No luck. It can't find the file 'FMX.Memo.Types.dcu''.

I've also tried other demos in the TMS demo's folders but none of them are working. Mainly for the same reason.

I also tried compiling my own 'FMX' barcode scanner on my laptop's built-in camera. I threw your camera component and a button and your barcodedecoder on a form. That worked, the camera, though it could not read a barcode, because its a cheap low-quality camera. But its still a successful compile and run.

But when I tried to compile it for Android, it failed with the following error:

[DCC Fatal Error] Unit1.pas(8): F2051 Unit FMX.TMSFNCUtils was compiled with a different version of Androidapi.JNIBridge.TJavaGenericImport`2.GetJavaClass

For what its worth providing here, in case this is the issue(s), these are my SDK Manager settings.

delphi - Android SDK Manager - original config 2022-10-28-fri
This image shows that state I was in and I could build android app's successfully since 2014.

Then, I decided to see if installing new (update-to-date) packages would solve the problems I am having with deploying Android apps currently. So, here are three images showing the current status and settings so far.

delphi - Android SDK Manager - new config 2022-10-29-sat.01

delphi - Android SDK Manager - new config 2022-10-29-sat.02

delphi - Android SDK Manager - new config 2022-10-29-sat.03

Please let me know if I am in the right direction and what I may need to install to get your components working. Thanks.

Another update..

Okay, I have spent many days downloading and installing all the Android API's and Tools using the Delphi XE7's Android SDK Tool to no avail, and I am still unable to compile any of the demo's for Android, and continue to receive the same error message at compile time:

[DCC Fatal Error] Unit1.pas(8): F2051 Unit FMX.TMSFNCUtils was compiled with a different version of Androidapi.JNIBridge.TJavaGenericImport`2.GetJavaClass

Just to note, I have Delphi XE7 Professional with FireDac and Mobile add-on's installed with Update 1 installed since 2014/2015.

Is there anything else I am missing? Otherwise, I'm sorry to say that the TMS FNC WX pack is not compatible with XE7. I was very interested in it.

Also, I'm interested in the TMS FNC Websocket components. But if the WX pack isn't working, then my guess is neither will the Websocket.

Please advise if there is anything else I can do to make this trial component work, thank you so much.

I suspect this must be an issue with the JAR file we need to deploy specifically in connection with XE7.
Possibly this requires a newer Android SDK. We'll investigate this.

The error, "was compiled with a different version" typically relates to precompiled DCU files for the Android platform that conflict with the Delphi XE7 version you are using. Did you install a trial version prior to installing a registered version? If so, please make sure that no old DCUs / BPLs & DCPs are installed on your system. Additionally, please make sure to check that the library path points to the correct and latest sources.

No, I only installed the Trial version, once. It's not just the demos that will not compile, it's also custom-made apps that I create from scratch that also will not compile and with the same error.