apply the style, "$type" property not found in Object descriptor


Did you manually load a style? If so, from which folder? Can you attach the style file? Are you using the latest version of TMS FNC Core & TMS FNC UI Pack both at designtime & runtime?

Yes, Open and open style
TMS FNC Core/style/

I tried to install the latest version but it didn't work..
Since the last version there are not many changes:

( Tuesday, June 16, 2020


After the first announcement a week ago, and a lot more tweaks and improvements we are proud to announce the first release of FNC Styles! FNC Styles is currently available for the TMS FNC UI Pack (v3.1) only. The core styling mechanism is implemented in TMS FNC Core (v2.3) and will be further pushed through other FNC components such as the TMS FNC Dashboard Pack in the future. FNC Styles targets 6 styles.

(I think the property lacks a name for which style to adopt)


We have tested this here and are not able to reproduce this issue. The style is properly applied. Are you sure you are using the latest version with all the latest changes? Are you able to change the style at runtime with the following code:

procedure TForm1.Button1Click(Sender: TObject);
  s: TTMSFNCStylesEditor;
  s := TTMSFNCStylesEditor.Create(Self);
  s.StylesForm := Self;

I didn't find an example.
Can you send a link to minimal examples.

Hi, the latest release of TMS FNC Core is 2.5, please download and use the latest release which should fix the issue

Not compile TMS FNC Core is 2.5:

LCLTMSFNCGraphicsTools.pas(55,39) Error: Identifier not found "TRGBTriple"

We are planning to release an update soon that should fix the issue with the missing TRGBTriple

Would you look at this problem as well, it existed in previous versions but I did not report it

LCLTMSFNCUtils.pas(1298,13) Error: Identifier not found "Tzseconds"
LCLTMSFNCUtils.pas(1492,21) Error: Identifier not found "Tzseconds"


We confirm this issue is fixed as well. Next version will address this.


There is the same problem with Style,
whether there is an example somewhere

the problem still exists
LCLTMSFNCUtils.pas(1332,13) Error: Identifier not found "Tzseconds"
LCLTMSFNCUtils.pas(1525,21) Error: Identifier not found "Tzseconds"

Against which Lazarus version are you testing? We are testing against Lazarus 2.0.12 with FPC 3.2.0. Tzseconds is a variable inside unixutil, can you confirm this? We have tested in Ubuntu 20.04.2 LTS. Tzseconds has been added a while ago, since last year so it's unclear why suddently this is an issue. We can only suspect that this is an issue in Lazazrus/FPC.

I wrote at the beginning

OS: Debian 10 (buster) LXDE
fpc 3.3.1
lazaraus 2.1

if this is a problem, i will see what i can use but for other things i will stay with lazarus 2.1 and fpc 3.3.1


We are currently only supporting the official Lazarus version available for download at which is version 2.0.12 which comes with the default FPC version of 3.2.0, all other newer versions or other custom FPC versions are not supported.

I have been writing on all my posts for three years now.


We are always happy to help out, but there are multiple versions / distributions of Lazarus as well as unofficial versions in combination with various FPC versions. We cannot provide support for all possible exotic combinations. We currently aim for the Lazarus build that can be downloaded directly from the home page.

I understand that I may have problems here.

I think this should work with style.

When the form is empty then the style is applied.

When form has any of your components then style makes an exception

I understand, but we have retested this here and couldn't see an issue with the styles with the latest version. Are you sure you are not compiling against an older version?

The new version is.
Can you email one example. Source and bin file for linux

I installed debian 10 lxde with lazarus 2.0.12 and fpc 3.2.0.
The style worked properly on that installation.
When I have problems, I will first check on this installation.

This is resolved. Thanks.

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.